import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:LLC_BI__Stage__c[\\S\\s\\r]*LLC_BI__Status__c|LLC_BI__Status__c[\\S\\s\\r]*LLC_BI__Stage__c)";
final String string = "<displayedFields>\n"
+ " <field>LLC_BI__Amount__c</field>\n"
+ " <isFieldManaged>false</isFieldManaged>\n"
+ " <isRequired>false</isRequired>\n"
+ "</displayedFields>\n"
+ "<displayedFields>\n"
+ " **<field>LLC_BI__Stage__c</field>**\n"
+ " <isFieldManaged>false</isFieldManaged>\n"
+ " <isRequired>false</isRequired>\n"
+ "</displayedFields>\n"
+ "<displayedFields>\n"
+ " <field>LLC_BI__lookupKey__c</field>\n"
+ " <isFieldManaged>false</isFieldManaged>\n"
+ " <isRequired>false</isRequired>\n"
+ "</displayedFields>\n"
+ "<displayedFields>\n"
+ " **<field>LLC_BI__Status__c</field>**\n"
+ " <isFieldManaged>false</isFieldManaged>\n"
+ " <isRequired>false</isRequired>\n"
+ "</displayedFields>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}