package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w[\w'.]*`)
var str = `Tierd-Branden This is (L.A.) 105 / New (Even L.A.A)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}