$re = '/(^|[^-])([A-Z])/m';
$str = 'dashed-String-With-Uppercase
camesCaseString';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;