#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(([A-Za-z]{3,9}:(?:\/\/)?(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)"
Local $sString = "asdf" & @CRLF & _
"http://google.com/" & @CRLF & _
"asfd" & @CRLF & _
"http://yahoo.com/logo.jpg" & @CRLF & _
"http://www.apple.com/sdfsd.php?page_id=13&id=18210&status=active#1" & @CRLF & _
"http://youtube.com/logo.png"
Local $sSubst = "<a href="$1">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)