package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:one)|(?:other))`)
var str = `one or the other`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}