$re = '/(?<!\w)@(\w+\b|\[.*?\](?=[\s+]|$))/';
$str = '@Test
Hello, this is a @[test1].[test2].[test3] string.
@[1:contact:Daniel Zahariev]+@[2:contact:Dankajuro].[1:contact:Daniel Zahariev]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);