$re = '/(?i)Create\s{1,20}+User\s{1,20}[a-zA-Z0-9_$#]{2,30}\s{1,20}Identified\s{1,20}by\s{1,20}\S{1,30}/m';
$str = 'CREATE USER books_admin IDENTIFIED BY MyPassword;
+[a-zA-Z0-9_$#]{2,30}\\s+Identified\\s+by\\S{2,60}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);