re = /<a.*?>.*leoshi.*<\/a>|(leoshi)/
str = 'leoshi
Sample text for testing:<a href="http://www.baidu.com" title="leoshi">leoshi</a>leoshi for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Sample text for testing:<a href="http://www.baidu.com" title="leoshi"> leoshi</a>bb leoshi for details balala...
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
<a href="http://www.baidu.com" title="leoshi">leoshi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end