$re = '/\d(?=nd)/';
$str = '1st, 2nd, 3pc, 4nd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);