package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(product_cats|product_tag|attr_color|attr_size)=[^,]+`)
var str = `?cgan=1&product_cats=mens-jeans,shirts&product_tags=fall,classic-style&attr_color=charcoal,brown&attr_size=large,x-small&cnep=0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}