const regex = /^(((0[1-9]|1[012])\/(?!00|29)([012]\d)|(0[13-9]|1[012])\/(29|30)|(0[13578]|1[02])\/31)\/(18|19|20)\d{2}|02\/29\/((18|19|20)(0[48]|[2468][048]|[13579][26])|2000))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((0[1-9]|1[012])\\\/(?!00|29)([012]\\d)|(0[13-9]|1[012])\\\/(29|30)|(0[13578]|1[02])\\\/31)\\\/(18|19|20)\\d{2}|02\\\/29\\\/((18|19|20)(0[48]|[2468][048]|[13579][26])|2000))$', '')
const str = `08/16/2005`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}