import re
regex = re.compile(r"<!--\[[^\]]*(?:](?!-->)[^\]]*)*]-->\R?")
test_str = ("<link rel=File-List href=\"filelist.xml\">\n"
"<!--[if gte mso 9]><xml>\n"
" <o:DocumentProperties>\n"
" <o:Revision>3</o:Revision>\n"
" <o:TotalTime>1</o:TotalTime>\n"
" <o:Created>2014-02-14T21:30:00Z</o:Created>\n"
" <o:LastSaved>2014-02-14T21:35:00Z</o:LastSaved>\n"
" <o:Pages>1</o:Pages>\n"
" <o:Words>58</o:Words>\n"
" <o:Characters>331</o:Characters>\n"
" <o:Lines>2</o:Lines>\n"
" <o:Paragraphs>1</o:Paragraphs>\n"
" <o:CharactersWithSpaces>388</o:CharactersWithSpaces>\n"
" <o:Version>15.00</o:Version>\n"
" </o:DocumentProperties>\n"
" <o:OfficeDocumentSettings>\n"
" <o:AllowPNG/>\n"
" </o:OfficeDocumentSettings>\n"
"</xml><![endif]-->\n"
"<link rel=themeData href=\"themedata.tx\">")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)