$re = '/\bмуқ\.\B/u';
$str = 'муқ. - муқоиса муқ. муқ.шавад муқ томуқ.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);