const regex = /^(?<digitsOnly>\p{N}{1,5}(?!\p{N}+))(?<miscellaneous>[-\p{L}\p{N}]+)$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<digitsOnly>\\p{N}{1,5}(?!\\p{N}+))(?<miscellaneous>[-\\p{L}\\p{N}]+)$', 'gmu')
const str = `12345a235
123a
12345-aa1
12345a
12345-a
-11
111111
aaaa
version 1 :: plain ... ^\\d{1,5}(?!\\d+)[-\\p{L}\\d]+\$
version 2 :: named ... ^(?<digitsOnly>\\p{N}{1,5}(?!\\p{N}+))(?<miscellaneous>[-\\p{L}\\p{N}]+)\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}