using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\,+(?![^\(]*\))";
string input = @"WATER, CORN SYRUP AND 2% OR LESS OF EACH OF THE FOLLOWING: CONCENTRATED JUICES (ORANGE, TANGERINE, APPLE, LIME, GRAPEFRUIT), CITRIC ACID, MALIC ACID, ASCORBIC ACID (VITAMIN C), THIAMIN HYDROCHOLORIDE (VITAMIN B1), NATURAL FLAVORS. MODIFIED CORNSTARCH, CANOLA OIL, CELLULOSE GUM, SUCRALOSE, SODIUM HEXAMETAPHOSPHATE, POTASSIUM SORBATE TO PROTECT FLAVOR, YELLOW #5, YELLOW #6 AND DISODIUM EDTA TO PROTECT COLOR.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}