package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\r?\n|\r)\d*)+(\r?\n|\r)`)
var str = `#Example-1#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-1#
#Example-2#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-2#
#Example-1#
The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.
jfbgfdgdf sgdsgsd.
#End Example-1#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}