$re = '/^(?:(?:25[0-5]|2[0-4]\d|1?\d\d?)\.){3}(?:25[0-5]|2[0-4]\d|1?\d\d?)$/m';
$str = '8.0.1.1
192.0.0.255
255.0.0.0
300.0.0.0
-25.0.0.0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);