#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)6to4|Teredo|Kernel\sDebug|WFP\sNative\sMAC|QoS\sPacket\sScheduler|WAN\sMiniport|Failover\sProvider|\s\-\sethernet_|LightWeight\sFilter|Npcap"
Local $sString = "Software Loopback Interface 1" & @CRLF & _
"Microsoft 6to4 Adapter" & @CRLF & _
"WAN Miniport (IKEv2)" & @CRLF & _
"WAN Miniport (IP)" & @CRLF & _
"Microsoft IP-HTTPS Platform Adapter" & @CRLF & _
"WAN Miniport (GRE)" & @CRLF & _
"WAN Miniport (Network Monitor)" & @CRLF & _
"Microsoft Kernel Debug Network Adapter" & @CRLF & _
"Microsoft Failover Cluster Virtual Adapter" & @CRLF & _
"WAN Miniport (IPv6)" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter #4" & @CRLF & _
"Microsoft Teredo Tunneling Adapter" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter" & @CRLF & _
"WAN Miniport (PPTP)" & @CRLF & _
"WAN Miniport (PPPOE)" & @CRLF & _
"WAN Miniport (SSTP)" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter #3" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter #2" & @CRLF & _
"WAN Miniport (L2TP)" & @CRLF & _
"Microsoft Failover Cluster Virtual Adapter-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"Microsoft Failover Cluster Virtual Adapter-Npcap Packet Driver (NPCAP)-0000" & @CRLF & _
"Microsoft Failover Cluster Virtual Adapter-QoS Packet Scheduler-0000" & @CRLF & _
"Microsoft Failover Cluster Virtual Adapter-WFP 802.3 MAC Layer LightWeight Filter-0000" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter #3-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"HPE Ethernet 1Gb 4-port 366FLR Adapter-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"DB" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver-Microsoft Load Balancing/Failover Provider-0000" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver-Npcap Packet Driver (NPCAP)-0000" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver-QoS Packet Scheduler-0000" & @CRLF & _
"Microsoft Network Adapter Multiplexor Driver-WFP 802.3 MAC Layer LightWeight Filter-0000" & @CRLF & _
"WAN Miniport (IP)-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"WAN Miniport (IP)-Npcap Packet Driver (NPCAP)-0000" & @CRLF & _
"WAN Miniport (IP)-QoS Packet Scheduler-0000" & @CRLF & _
"WAN Miniport (IPv6)-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"WAN Miniport (IPv6)-Npcap Packet Driver (NPCAP)-0000" & @CRLF & _
"WAN Miniport (IPv6)-QoS Packet Scheduler-0000" & @CRLF & _
"WAN Miniport (Network Monitor)-WFP Native MAC Layer LightWeight Filter-0000" & @CRLF & _
"WAN Miniport (Network Monitor)-Npcap Packet Driver (NPCAP)-0000" & @CRLF & _
"WAN Miniport (Network Monitor)-QoS Packet Scheduler-0000 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")