using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*<\/?tag>|(.*<\/.*?>)$";
string input = @"
<tag>
<tag>
<tag>
<i> abcd </i>
</tag>
</tag>
</tag>
<tag>
<tag>
efgh
</tag>
</tag>
<tag>
ijkl
</tag>
<tag>
mnop
</tag>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}