import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\"|\\')(?<key>[\\w\\d]+)(?:\\\"|\\')(?:\\:\\s*)(?:\\\"|\\')?(?<value>[\\w\\s-]*)(?:\\\"|\\')?";
final String string = "{\n"
+ " \"firstName\": \"John\",\n"
+ " \"lastName\": \"Smith\",\n"
+ " \"age\": 25,\n"
+ " \"address\": {\n"
+ " \"streetAddress\": \"21 2nd Street\",\n"
+ " \"city\": \"New York\",\n"
+ " \"state\": \"NY\",\n"
+ " \"postalCode\": \"10021\"\n"
+ " },\n"
+ " \"phoneNumber\": [\n"
+ " {\n"
+ " \"type\": \"home\",\n"
+ " \"number\": \"212 555-1239\"\n"
+ " },\n"
+ " {\n"
+ " \"type\": \"fax\",\n"
+ " \"number\": \"646 555-4567\"\n"
+ " }\n"
+ " ],\n"
+ " \"gender\": {\n"
+ " \"type\": \"male\"\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}