package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(< [\d.]{1,5})|([\d.]{1,5} - [\d.]{1,5})|(>= [\d.]{1,5})`)
var str = `< 6
7.44 - 17
>= 18`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}