const regex = /<\s*script\s*([^>]*)>(.*?)<\s*\/script\s*>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*script\\s*([^>]*)>(.*?)<\\s*\\\/script\\s*>', 'gs')
const str = `<script type="text/javascript" src="/openapi.js">
VK.init({apiId: 3251711, onlyWidgets: true});
var a = 5;
var b = 6;
</script>
<script type="text/javascript">
VK.init({apiId: 3251711, onlyWidgets: true});
var a = 5;
var b = 6;
for(a = 0; a<10;a++;
</script>
<script>
VK.init({apiId: 3251711, onlyWidgets: true});
var a = 5;
var b = 6;
for(a = 0; a<10;a++;
</script>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}