package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(a|b)\s*(?:=)\s*("[^"]*"|[^ ]*)`)
var str = `a="First Field" b=SecondField`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}