$re = '/(\w+)=(?:")?(.*?(?="?\s+\w+=|(?:"?)$))/';
$str = 'a="First Field" b=SecondField c="ThirdField" d="ThirdField" e=SecondField f=SecondField g="SecondField"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);