$re = '/^(?!.*?(&\||\|&|\(\)|!&|&!))/m';
$str = '(ABC)&(DFG)|!(ZXC)
!(ABC|DKJ)&VBN - pass
!(ADF&(!&(BER|CTY))|DGH)
!(ABC&DKJ)&|VBN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);