const regex = new RegExp('https?://www\\.domain\\.com/[^\\/-]*/', 'g')
const str = `http://www.domain.com/goodday/
http://www.domain.com/today-is-gooddady/
http://www.domain.com/life-is-good/enjoy-a-happy-life/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}