package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)G\(([^)]+)\)`)
var str = `not me G(select me, and me)
G(select me) G(also me)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}