$re = '/G\(([^)]+)\)(?:,|$)/m';
$str = 'not me G(select me, and me)
G(select me) G(also me)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);