re = /(?:(?![^<>]*(?:>))[^<])+/
str = 'das is<C strike ><c1>t ein text </c1></C><C u ><c1>der </c1></C><C b u ><c1>hier </c1></C>im <C i u ><c1>editor </c1></C><u></u>steht'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end