import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h[1-6]";
final String string = "<h2>Description</h2><p>It’s never been easier to transform your look with a Mid Length Dark Chestnut Wavy Full Cap Wig With Locks. The biggest advantage of full cap wigs is that they do not require prior preparation before being placed on the head. Simply braid your hair close to your head, cover your hair with a wig cap and place the full cap wig over your head.</p>\n"
+ "<p>Realistic wig model for every day or thematic event.</p>\n"
+ "<p>Mid Length Dark Chestnut Wavy Full Cap Wig With Lockshas an in-line special hat of breathable fabric that allows the wearing of the wig for a long time with maximum comfort. The hair is made from high quality heat resistant synthetic fibers which give the feeling of natural soft human hair.</p>\n"
+ "<p>Universal size – you can easily and quickly adjusted the width of the wig with the help of special bands that prevent it from moving. The model has a comfortable elastic adjustment zone and fits on each head.</p>\n"
+ "<p>The wig has its own hairstyle, but it can be changed if you want. Because the model is made from a high-quality fibers, it looks spectacular in appearance and leaves the feeling of real hair.</p>\n"
+ "<p>Place the crown of your attractive new and amazing vision with brand ModaWig!</p>\n"
+ "<p>Color that appears on your monitor could vary from the original color of the wig due to different monitor settings.</p>\n"
+ "<h2>Mid Length Dark Chestnut Wavy Full Cap Wig With Locks Dalia specifications:</h2>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">High quality heat resistant synthetic fiber hair similar to real human hair</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">Natural hairline transition enhanced with baby hair for more realistic look</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">Full and thick with 150% density.</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">Perfectly fit the curve of the head</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">Does not knots or tangles easily.</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">The size fits most people; you can adjust the hook inside the cap to the correct size to suit your head.</li>\n"
+ "</ul>\n"
+ "<ul>\n"
+ "<li style=\"color: #555555;\">The high-quality, heat resistant fibers make the hair natural, and soft on touch.</li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}