package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([[ ;(){},'"]?)(\b_[\w-]*\b)([] =;/*+"'{},-]?)`)
var str = `_var
test_var`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}