#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.+?) - (.*)"
Local $sString = "2016-12-08 10:09:16 - [ERROR] - from application - " & @CRLF & _
"! @72aki4439 - Internal server error, for (POST) [/rest/v1/item] ->" & @CRLF & _
"play.api.Application$$anon$1: Execution exception[[NullPointerException: null]]" & @CRLF & _
" at play.api.Application$class.handleError(Application.scala:296) ~[com.typesafe.play.play_2.11-2.3.8.jar:2.3.8]" & @CRLF & _
" at play.api.DefaultApplication.handleError(Application.scala:402) [com.typesafe.play.play_2.11-2.3.8.jar:2.3.8]" & @CRLF & _
"Caused by: java.lang.NullPointerException: null" & @CRLF & _
" at controllers.RestItem$2.apply(RestItem.java:577) ~[bla-1.0.jar:1.0]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")