$re = '/^(?!.*apple)[^.\n]*$/m';
$str = 'Some apple - false
Some other string - true
Some other string . - false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);