$re = '/(?:pass)(?:word)?(?:[\ ]{0,1})(?:[:=;,]{1})(?![\ ]{0,1}function)(.[^\s]*)/';
$str = 'password = potato123! found, is ok
$dbpass=train123; = found, is ok
pass:function($pass); = not found, is ok
$dbpassword= function(\'dontfindme\'); = found, should not be found';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;