const regex = /((\s*\S+){40})([\s\S]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\s*\\S+){40})([\\s\\S]*)', '')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas at venenatis leo. Aliquam interdum in mauris vitae feugiat. Cras feugiat metus eu arcu tempus vehicula. Curabitur eget elit ut ipsum fringilla dictum. Curabitur orci magna, facilisis ut finibus sed, vehicula quis enim. Cras ultrices enim id tellus placerat, ac tincidunt ipsum fermentum. Nam maximus nibh in vestibulum vehicula. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Suspendisse at porta mi. Nam aliquet ullamcorper cursus. Integer ultricies libero non risus malesuada, ut suscipit nisi sodales. Sed fringilla lacus id arcu vestibulum fermentum id pulvinar purus. Mauris elementum justo feugiat ipsum pulvinar varius. Donec vitae est facilisis, malesuada ex id, iaculis ipsum. Morbi cursus quam eu nisl dignissim, sit amet maximus turpis posuere. Proin posuere odio non diam rutrum, vitae ultricies neque fermentum. Praesent vel orci condimentum, placerat diam quis, cursus libero. Suspendisse ullamcorper odio a augue ultricies porttitor. Ut arcu risus, mollis id dignissim eu, tincidunt eu ante. Morbi aliquam metus sed nulla vehicula, ac volutpat tellus porta. Praesent tristique congue turpis ornare dignissim. Nullam mollis consectetur dui, quis pharetra massa tristique sed. Nullam nec nisl mattis, varius risus quis, dapibus quam. Donec aliquet elit a hendrerit viverra. Sed et nulla ipsum. Aenean at facilisis augue. Sed tristique ligula cursus ipsum pharetra convallis. Morbi suscipit, turpis aliquet placerat mollis, est sapien rhoncus ligula, vitae maximus mauris ipsum id est. Maecenas maximus in risus sit amet sodales. Suspendisse et felis in dui mattis sollicitudin vel scelerisque nibh. In a ipsum et magna rhoncus lacinia. Mauris iaculis, nibh nec vulputate mollis, mauris augue lobortis orci, in ultrices erat felis vitae mauris. Suspendisse varius condimentum sem, ut elementum tellus posuere et. Cras suscipit ante quis efficitur pretium. Curabitur ornare est quis dignissim vehicula. Donec vestibulum dolor sit amet ipsum condimentum, quis dictum mauris blandit. Ut interdum et felis quis maximus. Aenean ac enim quis justo ornare laoreet. Nunc semper elit nec augue tempus, eget interdum est feugiat. Aenean dapibus convallis ante eu ullamcorper. Duis sodales posuere porta. Vivamus non libero in elit ultrices ullamcorper et id elit. Duis nec tellus non ipsum varius luctus in nec neque. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Donec cursus placerat neque, quis varius elit pulvinar quis. Sed rhoncus blandit arcu, quis posuere massa tincidunt non. Aenean sollicitudin, quam non suscipit finibus, massa erat auctor nibh, ut rhoncus lectus neque ut urna. Nunc efficitur aliquam interdum. Fusce ultricies eu erat sed vestibulum. Maecenas ut nunc a lectus posuere vulputate et id justo. Nulla aliquet, erat et sodales lobortis, turpis diam dictum metus, sed eleifend tellus nunc eu purus. Praesent placerat porttitor arcu et eleifend. Nulla id mollis tellus, vitae sodales nibh. Ut mollis bibendum ex eu tincidunt. Integer semper vestibulum tempus. Praesent bibendum blandit sem, dapibus egestas sapien vehicula et. Nunc et eleifend sapien. Aenean massa quam, bibendum vitae leo ut, vulputate ullamcorper nulla. Proin interdum fringilla metus id malesuada. Sed enim risus, euismod vitae leo a, condimentum sagittis turpis. Etiam justo erat, vestibulum interdum leo nec, venenatis sollicitudin libero. In sit amet est at velit tempor auctor vitae vitae enim. Pellentesque scelerisque, tellus quis lacinia fermentum, libero tellus hendrerit nibh, et lobortis mi eros sed est. Curabitur at malesuada leo. Nunc sagittis enim ac ligula lacinia sollicitudin. Fusce non nunc ac nunc sagittis laoreet sed placerat orci. Mauris tempor ante sed odio placerat, eget sagittis neque commodo. Integer semper, sem ut egestas eleifend, dolor lectus malesuada orci, at tempus ipsum sem vulputate sem. Aenean quis egestas metus. Suspendisse aliquam orci finibus quam euismod, luctus lobortis libero vestibulum. Suspendisse potenti. Aenean feugiat.
`;
const subst = `$1...`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);