# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\w*\s\w*NIF\/CIF)(?<cRegexGroupsName>.*?)\s(?=\w*NIF\/CIF)"
test_str = "Dirección Provincial de: BIZKAIAUnidad de Recaudación Ejecutiva nº: 48/08Apellidos y nombre/R.Social: INFRAESTRUCTURAS VAL DIN 2001 S.A.0A95123568 812000059562248NIF/CIF: Nº de referencia: Domicilio: CL BERTENDONA 4 3 DP3 Tipo/Identificador: 10 48105556974 Régimen: 0111 Localidad: 48008 BILBAO Expediente: 48 08 20 00069160 Importe deuda pendiente: 122.779,79 Nº Documento: 48 08 312 20 025162050 DILIGENCIA DE EMBARGO DE CUENTAS CORRIENTES Y DE AHORRO (TVA-312) DESTINATARIO:"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.