$re = '/^(0|[1-9]\d*)$/m';
$str = '3234
0
2
0234
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);