use strict;
my $str = 'Together, Let\'s End Their War: Promoting a Culture of Health among Veterans on the Gulf - How strongly do you value your relationship with [Field-2]?
Together, Let\'s End Their War: Promoting a Culture of Health among Veterans on the Gulf - During the Clinical Scholars Program, with [Field-2], have you partnered new project(s) other than your team\'s Wicked Problem Impact Project?';
my $regex = qr/(?:\],\s*[^,]+)?\?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";