package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i) a-bom( |[!\",.:;?})\]])`)
var str = `De A-bom, Sint...`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}