package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\w.]+@[\w.]+|^\d+)$`)
var str = `asas@asas1212
12121s@d
121212
foo123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}