re = /,(?![^\[\]]*(?:\([^[]]]*\])?\])|,(?![^\{\}]*(?:\([^\{\}]]*\})?\})|\{|\}/
str = '{[d1].[m1], [d1].[m2]} , {[d1,mw],[d2].[d2,m2]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end