re = /(?<=^\d{3,7})\d(?=\d*$)|(?<=^[A-Z]{0,6})[A-Z](?=[A-Z]*$)|\d(?<=^\d{2,3})(?=\d?-\d{5}-\d{7}$)|\d(?<=^\d{3}-\d{1,5}(?:-\d{1,5})?)/m
str = '123-12345-1234567
AAAAAAAAA
12334567
'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result