re = /(?=^[a-z])(?=^[^A-Z]*[A-Z]{1}[^A-Z]*$)(?=^[^$@$!%*#?&]*[$@$!%*#?&][^$@$!%*#?&]*[$@$!%*#?&][^$@$!%*#?&]*$)^.{10}$/
str = 'asde@!Fghz'
# Print the match result
str.match(re) do |match|
puts match.to_s
end