package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+[MK])[,;\s]|(\d+[MK])$`)
var str = `10M, 20M, 30k`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}