re = /^(?!.*hede$).*$/m
str = 'obsolete hede
hede obsolete
obsolete hede obsolete'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end