$re = '/^(?P<question_id>[0-9]+)$/';
$str = '10920';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);