// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\d]+)").unwrap();
let string = "[\"100\"]
[\"100\",\"200\"]
[\"100\",\"200\",\"300\"]
[100]
[100,200]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}