import re
regex = re.compile(r"([-\[\]{}()*+?.,\\\/^$|#])")
test_str = "RewriteRule . - [E=REWRITEBASE:/]"
subst = "\\$1"
result = regex.sub(subst, test_str)
if result:
print(result)