$re = '/\b([a-zA-Z]|\d+)/i';
$str = 'My new project 2015';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);