# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE) # Start of definitions
(?P<str_double_quotes>
(?<!\\) # Not escaped
" # Match a double quote
(?: # Non-capturing group
[^\\] # Match anything not a backslash
| # Or
\\. # Match a backslash and a single character (ie: an escaped character)
)*? # Repeat the non-capturing group zero or more times, ungreedy/lazy
" # Match the ending double quote
)
(?P<str_single_quotes>
(?<!\\) # Not escaped
' # Match a single quote
(?: # Non-capturing group
[^\\] # Match anything not a backslash
| # Or
\\. # Match a backslash and a single character (ie: an escaped character)
)*? # Repeat the non-capturing group zero or more times, ungreedy/lazy
' # Match the ending single quote
)
(?P<brackets>
\( # Match an opening bracket
(?: # A non capturing group
(?&str_double_quotes) # Recurse/use the str_double_quotes pattern
| # Or
(?&str_single_quotes) # Recurse/use the str_single_quotes pattern
| # Or
[^()] # Anything not a bracket
| # Or
(?&brackets) # Recurse the bracket pattern
)*
\)
)
) # End of definitions
# Let's start matching for real now:
_n? # Match _ or _n
\s* # Optional white spaces
(?P<results>(?&brackets)) # Recurse/use the brackets pattern and put it in the results group
"""
test_str = ("_ (\"foo\") // want \"foo\"\n"
"_n(\"bar\", \"baz\", 42); // want \"bar\", \"baz\", 42\n"
"_n(domain, \"bux\", var); // want domain, \"bux\", var\n"
"_( \"one (optional)\" ); // want \"one (optional)\"\n"
"apples === 0 ? _( \"No apples\" ) : _n(\"%1 apple\", \"%1 apples\", apples) // could have on the same line two calls..\n\n"
"// misleading cases\n"
"_n(\"foo (\")\n"
"_n(\"foo (\\)\", 'foo)', aa)\n"
"_n( Array(1, 2, 3), Array(\")\", '(') );\n"
"_n(function(foo){return foo*2;}); // Is this even valid?\n"
"_n (); // Empty\n"
"_ ( \n"
" \"Foo\",\n"
" 'Bar',\n"
" Array(\n"
" \"wow\",\n"
" \"much\",\n"
" 'whitespaces'\n"
" ),\n"
" multiline\n"
"); // PCRE is awesome")
matches = re.finditer(regex, test_str, re.DOTALL | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.